Configurações de proxy do sistema no ubuntu

20

Eu queria usar a internet no meu servidor proxy da faculdade, que também requer autenticação. Eu procurei no google por soluções e a melhor solução que encontrei ainda foi isso . Eu modifiquei o script na resposta aceita para incluir a autenticação. Aqui vai:

if [ $(id -u) -ne 0 ]; then
echo "This script must be run as root";
exit 1;
fi

if [ $# -eq 4 ] then

gsettings set org.gnome.system.proxy mode 'manual' ;
gsettings set org.gnome.system.proxy.http host '$1';
gsettings set org.gnome.system.proxy.http port $2;
gsettings set org.gnome.system.proxy.http authentication-user '$3';
gsettings set org.gnome.system.proxy.http authentication-password '$4';


grep PATH /etc/environment > lol.t;
printf \
"http_proxy=http://$3:[email protected]$1:$2/\n\
 https_proxy=http://$3:[email protected]$1:$2/\n\
 ftp_proxy=http://$3:[email protected]$1:$2/\n\
 no_proxy=\"localhost,127.0.0.1,localaddress,.localdomain.com\"\n\
 HTTP_PROXY=http://$3:[email protected]$1:$2/\n\
 HTTPS_PROXY=http://$3:[email protected]$1:$2/\n\
 FTP_PROXY=http://$3:[email protected]$1:$2/\n\
 NO_PROXY=\"localhost,127.0.0.1,localaddress,.localdomain.com\"\n" >> lol.t;

 cat lol.t > /etc/environment;


 printf \
 "Acquire::http::proxy \"http://$3:[email protected]$1:$2/\";\n\
  Acquire::ftp::proxy \"ftp://$3:[email protected]$1:$2/\";\n\
  Acquire::https::proxy \"https://$3:[email protected]$1:$2/\";\n" > /etc/apt/apt.conf.d/95proxies;

rm -rf lol.t;

else

printf "Usage $0 <proxy_ip> <proxy_port> <username> <password>\n";

fi

No entanto, contas on-line ainda não funcionam (mesmo para o rhythmbox e outros programas GTK3) . Uma tela branca aparece assim:

Alguma sugestão sobre como isso pode ser resolvido?

    
por Raman 23.08.2015 / 09:43

4 respostas

25

Resolveu finalmente:

(Siga os passos em série)

1. Para programas gtk3, como o rhythmbox e contas on-line:

Primeiro, você precisa inserir as configurações de proxy nas configurações de rede (junto com a autenticação):

Emseguida,apliquetodoosistema.

2.Paraapt,centrodesoftware,etc

editeoarquivo/etc/apt/apt.conf

Emseguida,substituatodootextoexistentepelasseguinteslinhas

Acquire::http::proxy"http://username:[email protected]:port/";
Acquire::ftp::proxy "ftp://username:[email protected]:port/";
Acquire::https::proxy "https://username:[email protected]:port/";

3. Variáveis de ambiente

edite o arquivo /etc/environment

E adicione as seguintes linhas depois de PATH="alguma coisa aqui"

http_proxy=http://username:[email protected]:port/
ftp_proxy=ftp://username:[email protected]:port/
https_proxy=https://username:[email protected]:port/

Isso é tudo ..

    
por Raman 23.08.2015 / 11:32
1

Para fazer o download de pacotes pelo wget proxy tem que ser configurado em / etc / environment, e para baixar pacotes pelo apt-get proxy tem que ser configurado em /etc/apt/apt.conf

    
por sauser 12.07.2016 / 12:10
1

Isso não é tudo, claro. Mais alguns programas ( npm , curl e git ):

npm config set proxy $HTTP_PROXY
npm config set https-proxy $HTTPS_PROXY
npm config set strict-ssl false
echo "proxy = $HTTP_PROXY" > ~/.curlrc
echo "noproxy = $NO_PROXY" >> ~/.curlrc
git config --global http.proxy $HTTP_PROXY
git config --global https.proxy $HTTPS_PROXY

Para o Maven, edite ~/.m2/settings.xml . O IntelliJ também não parece pegar a configuração global.

    
por MPi 05.09.2017 / 11:29
0

Para fazer com que wget trabalhe com um proxy, eu adicionaria também para criar um .wgetrc em seu diretório inicial, contendo:

http_proxy = http://proxy:port/
https_proxy = http://proxy:port/
proxy_user = user
proxy_password = password
use_proxy = on
wait = 15
    
por trudide12 21.04.2016 / 10:11

Tags