Suponho que você tenha uma linha como " hosts: files mdns dns " em /etc/nsswitch.conf . Isso controla quais origens são usadas para fazer buscas de nomes - files diz ao sistema para consultar / etc / hosts, mdns usa o daemon avahi para procurar nomes via DNS multicast (Bonjour / ZeroConf), e dns é um pesquisa normal de DNS para servidores em /etc/resolv.conf . (O ping deb02.local provavelmente só funcionará quando estiverem juntos na mesma rede; com um roteador intermediário ou se o deb02 tiver sido desativado por algum tempo, ele também falhará.)
host , nslookup e dig são ferramentas para fazer especificamente consultas DNS e ignorar outros métodos listados em nsswitch.conf ; ping irá passar por todos eles.
Por padrão, as entradas resolv.conf são consultadas em ordem, passando para a próxima na lista somente quando você obter um tempo limite ou erro interno ( SERVFAIL ). Um nome que não existe ( NXDOMAIN ) não vai te mover para baixo na lista. Assim, se você tiver um domínio interno, os servidores que o conhecem devem ser listados primeiro. Quando é o MS Active Directory, você deseja listar apenas os servidores DNS MSAD - geralmente seus controladores de domínio - no resolv.conf.
Como seu nome de domínio do AD corresponde ao mydomain.com em seu caminho de pesquisa, e seu DNS do AD não apresenta nenhum registro MX para seu domínio, o postwill está recorrendo ao comportamento de fallback de tentar entregar a um host de um consultar registros A para o destino (aqui, mydomain.com em si.) Um servidor do AD retornará o conjunto de controladores de domínio para essa consulta, e os DCs do AD geralmente não executam um MTA, e é por isso que você está vendo tempos limite de conexão.
Normalmente, você terá um servidor de e-mail local configurado como smarthost ( relayhost é a configuração do postfix) ou você pode adicionar uma regra de transporte de postfix apenas para mydomain.com para apontar para o servidor de e-mail apropriado para seu domínio.