Você pode fazer isso:
git clone https://github.com/freebsd/freebsd.git /usr/src
cd /usr/src; make clean
Estou tentando executar uma atualização do freebsd10 e estou sendo perguntado sobre as fontes do kernel
===>>> Launching child to update lsof-4.89.b,8 to lsof-4.89.d,8
===>>> All >> lsof-4.89.b,8 (9/9)
===>>> Currently installed version: lsof-4.89.b,8
===>>> Port directory: /usr/ports/sysutils/lsof
===>>> This port is marked IGNORE
===>>> requires kernel sources
===>>> If you are sure you can build it, remove the
IGNORE line in the Makefile and try again.
===>>> Update for lsof-4.89.b,8 failed
===>>> Aborting update
mas o sysinstall não existe mais
sysinstall: not found
Qual é o novo método de instalar os fontes do kernel no FreeBSD10?
Eu achei o bsdinstall, mas ele apenas tenta copiar meu disco, o que eu não quero
Você pode fazer o download e extrair manualmente um tarball da árvore de código-fonte completo para sua versão específica a partir de ftp: // ftp. freebsd.org/pub/FreeBSD/releases/
Por exemplo,
fetch ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/
10.2-RELEASE
/src.txztar -C / -xzvf src.txz
10.2-RELEASE
MUST be replaced with correct version of your OS.One can find version using command:
freebsd-version -k
The minor versions should be ignored to fetch from the above URL. For ex: if it is
10.2-RELEASE-p1
, just use:10.2-RELEASE
Uma solução um pouco mais genérica:
fetch -o /tmp ftp://ftp.freebsd.org/pub/'uname -s'/releases/'uname -m'/'uname -r | cut -d'-' -f1,2'/src.txz
tar -C / -xvf /tmp/src.txz
E você pode substituir /tmp
pelo seu diretório favorito para fazer o download das coisas.
Ou:
svn checkout https://svn.freebsd.org/base/releng/'uname -r | cut -d'-' -f1,1' /usr/src