Como faço para lidar com erros de “fontes não autenticadas” no Centro de Software?

118

Qualquer instalação que estou tentando no Centro de Software está me dizendo:

Requires installation of untrusted packages: The action would require the installation of packages from not authenticated sources.

Eu fiz um apt-get update da linha de comando, removi as origens de software das quais as chaves estavam ruins (adicionei os PPAs) e desmarquei-as nas fontes de software para o centro de software, mas não adiantou. Não consigo mais instalar nada do centro de software - apenas > da linha de comando com o apt-get.

Está desinstalando / instalando a única opção? Eu não quero quebrar outros PPAs que eu tenho.

Informações adicionais:

Aqui está uma pasta do apt-get update:

Reading package lists... Done
W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B725097B3ACC3965
W: GPG error: http://us.archive.ubuntu.com oneiric Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

Eu tentei a atualização do apt-key, e não houve efeito (duas chaves inalteradas).

A saída de apt-get update e apt-get upgrade e o conteúdo de /etc/apt/sources.list podem ser encontrados em esta postagem pastebin .

    
por b. e. hollenbeck 06.12.2011 / 17:29
fonte

4 respostas

106

Abra o Terminal e insira os comandos abaixo, um por um:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

Atualização: Isso pode não ajudar em algumas versões posteriores, o que pode exigir soluções alternativas como a da outra resposta, ou essa que parece fazer o trabalho em alguns casos no Ubuntu 16.04:

sudo apt-get update
sudo apt-get dist-upgrade
    
por Sadi 21.02.2012 / 10:45
fonte
67

Este é um problema comum com os PPAs do Launchpad. Comum o bastante para ter copiado esses comandos para uso quando eu reinstalar ou adicionar novos PPAs do Launchpad.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys  

Então,

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys YOURKEYNUMBERHERE  

Substitua YOURKEYNUMBERHERE pelas chaves do problema, assim:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B725097B3ACC3965  

e

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5  

A primeira linha é quase a mesma, menos as chaves. Pode até ser opcional, eu sinceramente não sei. Tudo o que tenho certeza é que esse método sempre corrige o problema imediatamente.

Se alguém encontrar a resposta original que eu copiei, entre em contato comigo e eu atribuirei a eles a atribuição.

** EDIT É quase certamente a resposta do karthik87 aqui ou aqui eu tenho isso de. Isso provavelmente pode ser fechado como duplicado.

De qualquer forma, não se esqueça de fazer um

sudo apt-get update  

depois, para consertar tudo.

Nota: Executar apt-get update primeiro deve fornecer uma mensagem de erro mencionando qual chave está faltando e um ID a ser usado com o comando apt-key.

    
por Tom Brossman 06.12.2011 / 20:55
fonte
6

Talvez você possa tentar mudar para o servidor principal em Fontes de software , onde é exibido Download de .

    
por foh1981 06.12.2011 / 18:04
fonte
0

Requer a instalação de pacotes não confiáveis: A ação exigiria a instalação de pacotes de fontes não autenticadas.

Recebi este erro do Ubuntu Software Updater depois de adicionar um repositório sem adicionar a chave para o repositório. Alguns repositórios de software são bons em fornecer instruções sobre como adicionar suas chaves de repositório junto com as instruções para adicionar o repositório, como o Launchpad.Outros apenas fornecem a chave.

Para descobrir qual chave você precisa em uma execução de terminal:

sudo apt-get update

Isso fará o download da lista de pacotes disponíveis de seus repositórios que usam as chaves. Se uma chave estiver faltando, retornará uma mensagem de erro.

Use as informações na mensagem de erro para encontrar e baixar a chave e adicioná-la ao seu keyring apt com:

sudo apt-key add /PathToTheKeyFile/KeyFile.gpg

Você deve receber de volta um OK . Agora, para testar se você tem todas as chaves de autenticação de repositório necessárias para permitir que o Ubuntu Software Updater seja executado:

sudo apt-get update

Isto irá novamente baixar a lista de pacotes disponíveis de seus repositórios que usam as chaves. Se uma chave estiver faltando, retornará uma mensagem de erro.

    
por frederickjh 15.02.2017 / 11:15
fonte