Os serviços de localização estão sempre desativados no Mac OS X Lion

2

Um programa de serviços de localização simples estava funcionando bem na minha máquina e de repente parou de funcionar. Após explorar ainda mais o problema, percebi que algum processo desativou os serviços de localização em Preferências do Sistema »Segurança & Privacidade »Privacidade .

Eu verifiquei Ativar serviços de localização , mas novamente ele foi desativado automaticamente.

Após algumas pesquisas, descobri que não é apenas o meu programa, até mesmo as funções integradas do sistema também estão falhando devido a esse problema, por exemplo Preferências do sistema »Data & Time »Time Zone falhou ao obter a localização atual.

Sempre que verifico Ativar serviços de localização , vejo o seguinte erro nos registros do console:

16/10/12 11:23:15.636 AM [0x0-0x42042].com.apple.systempreferences: ERROR,Time,372059595.636,Function,"CLInternalSetLocationServicesEnabled",CLInternalSetLocationServicesEnabled failed
16/10/12 11:23:15.638 AM [0x0-0x42042].com.apple.systempreferences: STACK,Time,372059595.636,1   CoreLocation                        0x00007fff8f9957be CLInternalSetLocationServicesEnabled + 110

Notas:

  • O WiFi está em
  • Eu não instalei o iOS Simulator
  • eu uso o Xcode versão 4.5 (4G182)
  • Eu uso o Boot Camp e fiz minha inicialização dupla do MacBook Pro (Mac OS X Lion e Windows 7)
  • Eu faço apenas o desenvolvimento do Mac, mas não o iOS
por rplusg 16.10.2012 / 09:14

2 respostas

1

#!/bin/sh
launchctl unload /System/Library/LaunchDaemons/com.apple.locationd.plist

defaults write /System/Library/LaunchDaemons/com.apple.locationd Disabled -bool false 

then

launchctl load /System/Library/LaunchDaemons/com.apple.locationd.plist

exit 0
    
por 12.04.2014 / 09:28
0

Estou encontrando o mesmo problema no OSX 10.11 (El Capitan).

Eu encontrei esta postagem ( link ). Eu corri o script dentro e, finalmente, meus serviços de localização foram corrigidos.

#!/bin/bash

########################## SET SYSTEM TIME  ##################################################
#
# Written by Tim Kimpton
#
# using information from https://jamfnation.jamfsoftware.com/discussion.html?id=5336
#
# If the machine is 5 minutes out of the kdc the machine will not bind to the domain.
#
# This script does the folling to ensure the time is correct
#
# 1. Unload the launch daemon used for location services
#
# 2. Get the hardware UUID of the machine and put it in the location services db
#
# 3. Enable location services
#
# 4. Correct permissions on the database file used for location services
#
# 5. Set the time zone to update the time automatically
#
# 6. Set the network time to on
#
# For information see https://jamfnation.jamfsoftware.com/discussion.html?id=5336
###############################################################################################

######################### ENVIRONMENT VARIABLES #######################

# Get the Hardware UUID from system profiler
uuid=$(/usr/sbin/system_profiler SPHardwareDataType | grep "Hardware UUID" | cut -c22-57)

####################### DO NOT MODIFY BELOW THIS LINE #################

# Unload the launch daemon
/bin/launchctl unload /System/Library/LaunchDaemons/com.apple.locationd.plist

# Write the UUID to the hidden plist file and initialise it
/usr/bin/defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd."$uuid" LocationServicesEnabled -int 1

# Enable Location Services
/usr/bin/defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd.notbackedup."$uuid" LocationServicesEnabled -int 1

# Make sure the permissions on the database file is correct
/usr/sbin/chown -R _locationd:_locationd /var/db/locationd
/bin/launchctl load /System/Library/LaunchDaemons/com.apple.locationd.plist

# Set time zone to update automatically
/usr/bin/defaults write /Library/Preferences/com.apple.timezone.auto Active -bool true

# Set network time to on
/usr/sbin/systemsetup -setusingnetworktime on > /dev/null 2>&1

exit 0
    
por 26.10.2015 / 21:13