Eu tenho batido minha cabeça com um problema aqui, e agora estou pedindo ajuda na internet.
Eu tenho um sistema rodando o Mandrake Linux, com a seguinte configuração:
-
/dev/hda - Esta é uma unidade IDE. Tem algumas partições nele que inicializam o sistema e compõem a maior parte do sistema de arquivos.
-
/dev/sda - Esta é a unidade 1 de 2 para uma invasão de software /dev/md0
-
/dev/sdb - Esta é a unidade 2 de 2 para uma invasão de software /dev/md0
md0 é montado, mas fstab como /data-storage , portanto, não é essencial para a capacidade do sistema inicializar. Podemos comentar isso em fstab , e o sistema funciona bem de qualquer forma.
O problema é que temos uma unidade sdb com falha. Então eu fechei a caixa e peguei o disco com falha e instalei um novo disco.
Quando o sistema é inicializado, /proc/mdstat mostra apenas sda como parte do raid. Em seguida, executo o comando various para reconstruir o RAID para /dev/sdb . Tudo é reconstruído corretamente e, após a conclusão, você olha para /proc/mdstat e mostra 2 unidades sda1(0) e sdb1(1) . Tudo parece ótimo.
Então você reinicia a caixa ... UGH !!!
Após a reinicialização, sdb está ausente novamente do RAID. É como se a reconstrução nunca tivesse acontecido. Posso percorrer os comandos para reconstruí-lo novamente e ele funcionará, mas, novamente, após a reinicialização, a caixa parece fazer com que sdb simplesmente desapareça!
O que é realmente estranho é que, após a reinicialização, eu retiro o sda da caixa e tento fazer com que o sistema carregue com a unidade sdb reconstruída no sistema e, quando o faço, o sistema realmente gera um erro depois do grub, e diz algo sobre o erro da unidade, e o sistema tem que desligar.
Pensamentos ??? Estou começando a me perguntar se o grub tem algo a ver com essa bagunça. Que a unidade não está sendo configurada no grub para ser visível na inicialização? Esta matriz RAID não é necessária para o sistema inicializar, mas quando a unidade de substituição está lá, sem SDA, ela não inicializa o sistema, então isso me faz acreditar que há algo nisso. Além disso, parece haver algo muito instável aqui, o drive caindo do RAID após a reinicialização.
Eu acertei o ponto de bater minha cabeça no teclado. Qualquer ajuda seria muito apreciada !!!