I want this computer to be connected to the internet. What am I doing wrong?
Informações resumidas
Recuperando informações da discussão em Usando o Juniper EX3300 como roteador :
-
ge-0/1/0recebe um endereço público / 30 da Cogent. Para fins de ilustração, chamaremos o endereço do EX3300 nesta sub-rede192.0.2.109/30. Seu gateway padrão é192.0.2.110/30. Na configuração acima, você atribuiuge-0/1/0avlan.1usando vlan-id 3. -
ge-0/0/0também recebe um endereço IP público. Por uma questão de argumento, esta sub-rede é192.0.2.208/28. A sub-rede dege-0/0/0é diferente dege-0/1/0. O endereçamento da interface (e algumas outras coisas) precisa ser corrigido.
Lista de itens para corrigir
- Você não pode atribuir
192.0.2.208/28ao servidor Ubuntu. .208 é o endereço de sub-rede e .223 é o endereço de broadcast. Endereços de host válidos neste intervalo de sub-rede de192.0.2.209a192.0.2.222(não importa que eu esteja usando endereços RFC 5737 aqui, a matemática da sub-rede funciona da mesma forma. - Você precisa de
l3-interface vlan.1para seu link / 30 para o roteador Cogent; no entanto, você também tem a máquina Ubuntu na mesma sub-rede em um / 28. Agora que estabelecemos que o servidor Ubuntu está em uma sub-rede diferente dege-0/1/0, siga as práticas padrão de engenharia da Internet e atribua uma vlan diferente a essa sub-rede . Vamos chamá-lo del3 interface vlan.100comvlan-id 100no seu EX3300. Atribua192.0.2.209/28ao seuvlan.100no EX3300 e use-o como o gateway padrão para essa nova sub-rede. - Mesmo que você tenha atribuído um endereço de host válido ao seu servidor Ubuntu (veja o ponto 1., acima), o gateway padrão desse servidor deve estar na mesma sub-rede. Atribua
192.0.2.210/28ao servidor Ubuntu e torne o gateway padrão192.0.2.209.
Material puramente informativo
FYI, também dissemos que você não pode usar endereços IP privados (RFC 1918) sem NAT (RFC 3022) . Vejo que você tem 10.0.1.1/24 atribuído a vlan.0 . Qualquer coisa em 10.0.0.0/8 é o espaço RFC 1918 . Se esses dispositivos precisarem acessar a internet, você precisará de algum tipo de NAT.
Posso sugerir:
- um bom livro sobre roteamento na internet ; é voltado para o Cisco IOS, mas os conceitos ainda são muito semelhantes.
- um bom livro sobre TCP / IP
Boa sorte para você neste esforço.